[Logo] TCC discussion forum
  [Search] Search   [Recent Topics] Recent Topics   [Hottest Topics] Hottest Topics   [Top Downloads] Top Downloads   [Groups] Back to home page 
[Register] Register /  [Login] Login 

Cannot output menu to I2C 20x04 LCD RSS feed
Forum Index » tcMenu Arduinio library
Author Message
Peter


Joined: Feb 2, 2021
Messages: 2
Offline
So I've been at this for several days now with no luck, and it's time to ask for help! I promise I've searched the forum and read everything I can.

So I can get my I2C 20x04 LCD display running fine with the LiquidCrystalIO > HelloI2C example. So my hardware is fine.

I'm starting with the most straightforward simple menu I can create, to get it working first, and then go from there. The example I created was literally a single analogue item in Tc Menu Designer 1.7.5 for MacOS. This compiles perfectly, and uploads to my device, but nothing is appearing on the screen. From what I have read, I don't need to call anything and by default the menu should appear but this is not happening. It must be something simple, but I'm baffled. Where do I start?

Edit to add: I've got an encoder set up on pins 2 and 3, with the switch on pin4. I'm using an Arduino Mega 2560. I've followed this exactly: https://www.thecoderscorner.com/products/arduino-libraries/tc-menu/tcmenu-overview-quick-start/ and I'm getting nothing at all.

 Filename tcmenu_testproject_02_02_2021.zip [Disk] Download
 Description No description given
 Filesize 11 Kbytes
 Downloaded:  19358 time(s)

davetcc


Joined: Jan 19, 2019
Messages: 532
Offline
Thanks for reporting with all the details, I'll try and build the project later today using Arduino and feedback here.
davetcc


Joined: Jan 19, 2019
Messages: 532
Offline
In the designer code generator, under display settings, there's an option for the "LCD Pin Layout". I think you've picked the opposite one to which is the default in the HelloI2C sketch. Could you try the other option please and let me know if it works.

It will have options for RS_RW_EN and EN_RW_RS. Basically, can you try the other option?

Many thanks.
davetcc


Joined: Jan 19, 2019
Messages: 532
Offline
A bit more background.

Basically, the I2C backpacks are not standard, some use RS-RW-EN and some use EN-RW-RS. We don't try to guess them, instead, we just rely on you trying both options.
Peter


Joined: Feb 2, 2021
Messages: 2
Offline
Bravo! Solved. Many, many thanks! Was indeed the weird I2C.
 
Forum Index » tcMenu Arduinio library
Go to:   
Mobile view
Powered by JForum 2.7.0 © 2020 JForum Team • Maintained by Andowson Chang and Ulf Dittmer

This site uses cookies to analyse traffic, serve ads by Google AdSense (non-personalized in EEA/UK), and to record consent. We also embed Twitter, Youtube and Disqus content on some pages, these companies have their own privacy policies.

Our privacy policy applies to all pages on our site

Should you need further guidance on how to proceed: External link for information about cookie management.